Search found 195 matches

by SkippyDo
Sun May 31, 2020 7:01 pm
Forum: Mobile Apps
Topic: Another API issue..
Replies: 17
Views: 2996

Re: Another API issue..

Sent you message. You should have access to any events (though any single one of them ought to be OK). If you can help me figure out ADB again I can dig deeper. One thing not mentioned is that my phone's rooted: not sure if I'd read of this presenting any issues w/regard to zmNinja.

Many thanks.
by SkippyDo
Sun May 31, 2020 1:59 am
Forum: Mobile Apps
Topic: Another API issue..
Replies: 17
Views: 2996

Re: Another API issue..

I disabled Chrome and installed WebView but that doesn't rectify; perhaps there's some setting to make zmNinja see/understand this? Again, I can view event playback while logged in to the ZM console via Firefox, though I have to specify MJPEG as the codec. Logs (which I can provide, but just wanted ...
by SkippyDo
Sun May 31, 2020 1:28 am
Forum: ZoneMinder 1.34.x
Topic: Live view constantly cycles (zms socket errors)
Replies: 5
Views: 606

Re: Live view constantly cycles (zms socket errors)

That seems to be the case. If you can give me a specific set of parameters/settings to go through to test I can report back. My impression was that the prevalence of socket errors dropped once I kicked the bandwidth setting down: setting within ZM's console (also for my user) as well as on the clien...
by SkippyDo
Fri May 29, 2020 9:21 pm
Forum: Mobile Apps
Topic: Another API issue..
Replies: 17
Views: 2996

Re: Another API issue..

OK, I've found the cause of the Android phone issue. CODEC is set to Auto by default. I can change this within a browser, but not within zmNinja. If, within a browser, I set it to MJPEG it will display (though I'm still subjected to socket issues, which is a separate, though previously commented on,...
by SkippyDo
Fri May 29, 2020 8:52 pm
Forum: ZoneMinder 1.34.x
Topic: [CLOSED]API problems/errors
Replies: 16
Views: 1786

Re: API problems/errors

OK... so this all is looking like a network issue. How, exactly, I'm not sure... Setting cameras to 1280x720 and BANDWIDTH_DEFAULT to "Low" gets me (so far) steady output of live streaming for all of my devices. BUT... Event playback is suffering when playing remotely. On my Android phone it doesn't...
by SkippyDo
Fri May 29, 2020 7:54 pm
Forum: Mobile Apps
Topic: Another API issue..
Replies: 17
Views: 2996

Re: Another API issue..

Ugh... I'm back to having problems. Likely NOT a zmNinja issue, though I'm reporting here to help [re]direct others. Live stream works, but event playback (on my Android phone) does not. Seems that I might have TWO separate issues teaming up on me here. And it is affecting Event playback. Under IOS ...
by SkippyDo
Thu May 28, 2020 7:53 pm
Forum: ZoneMinder 1.34.x
Topic: ZM is running - So what's next? Stoopid Noob questions
Replies: 8
Views: 938

Re: ZM is running - So what's next? Stoopid Noob questions

Somewhere in all this you SHOULD set up automated database backups. I have a server with an SSD as its system disk and a separate HD (2TB?) for all data. HD is partitioned for web pieces and ZM data (events etc.), and another partition for mysql DB (also have a separate partition for backups and sof...
by SkippyDo
Thu May 28, 2020 7:28 pm
Forum: Mobile Apps
Topic: Another API issue..
Replies: 17
Views: 2996

Re: Another API issue..

Just wanted to follow up... Rather out of the blue zmNinja started being able to connect up to Monitors and all else. I really have no idea what exactly caused this to occur: I ran into some socket errors on the server running from a web browser and when kicking the Bandwidth setting down to Medium/...
by SkippyDo
Thu May 28, 2020 7:16 pm
Forum: ZoneMinder 1.34.x
Topic: Live view constantly cycles (zms socket errors)
Replies: 5
Views: 606

Re: Live view constantly cycles (zms socket errors)

I think I have found the source/reason for the problem! I set the web Bandwidth to Medium and that stopped the errors and the constant refreshing. Went ahead and set it to Low just to make sure. Might want to add this note to the error tips? Having issues getting Montage Review to load. Might be too...
by SkippyDo
Wed May 27, 2020 8:24 pm
Forum: ZoneMinder 1.34.x
Topic: Live view constantly cycles (zms socket errors)
Replies: 5
Views: 606

Live view constantly cycles (zms socket errors)

Somewhere along the line I started getting socket errors. OS: Debian Buster (all current) ZM: 1.34.15 Cameras: DaHua IPC-HFW1320S (ZM config'd to use H264 passthrough; Source Path: rtsp://<user>:<password>@192.168.1.[108..111]; Method is TCP) To produce error: Open up Console in web browser (Firefox...
by SkippyDo
Wed May 27, 2020 5:46 pm
Forum: ZoneMinder 1.34.x
Topic: Setting SSL variables
Replies: 5
Views: 602

Re: Setting SSL variables

OK, MANY thanks for the clarification!
by SkippyDo
Wed May 27, 2020 5:44 pm
Forum: ZoneMinder 1.34.x
Topic: [CLOSED]API problems/errors
Replies: 16
Views: 1786

Re: API problems/errors

Doesn't the database have to be queried in order to authenticate? Different mechanism than API calls? I can bring up the montage review screen but I see static images of each camera view with "no data" messages overlain. If I pick a time frame, say 8hrs, nothing comes up (there are events shown in t...
by SkippyDo
Wed May 27, 2020 2:51 pm
Forum: ZoneMinder 1.34.x
Topic: Setting SSL variables
Replies: 5
Views: 602

Re: Setting SSL variables

As I noted, ZM components are referencing THREE variables associated with SSL. In 1.30.4 I used TWO (configured in zm.conf).

Yes, I am having API issues. That is why I am asking why a packaged component is showing three ZM-specific variables associated with SSL. Perhaps you aren't aware of this?
by SkippyDo
Tue May 26, 2020 5:28 pm
Forum: ZoneMinder 1.34.x
Topic: [CLOSED]API problems/errors
Replies: 16
Views: 1786

Re: API problems/errors

Does the fact that I can run things out of "host" (getVersion.json; getload.json etc.) mean that the API facility is working, that it is purely only the database connection that is failing? BUT... isn't authentication requiring database access? I have tried everything, even statically setting variab...
by SkippyDo
Tue May 26, 2020 5:38 am
Forum: ZoneMinder 1.34.x
Topic: Setting SSL variables
Replies: 5
Views: 602

Setting SSL variables

In pursuit of some API issues ( https://forums.zoneminder.com/viewtopic.php?f=40&t=29428&sid=68a54a38d90f8da47f4ee14da7d13e36 ) I started digging through php code and found that database.php.default references three ZM SSL variables: 'ssl_ca' => ZM_DB_SSL_CA_CERT, 'ssl_key' => ZM_DB_SSL_CLIENT_KEY, ...