Search found 85 matches

by lpallard
Mon Oct 07, 2013 11:15 pm
Forum: ZoneMinder 1.26.x
Topic: How can I make sure libjpeg-turbo is being used
Replies: 5
Views: 3699

Re: How can I make sure libjpeg-turbo is being used

When I set the source color depth to 32 bit, I immediately get :

"libjpeg-turbo is required for JPEG encoding directly from RGB32 source"

in the logs... So I am sure that its not using libjpeg-turbo... If I only could make it work ;)
by lpallard
Mon Oct 07, 2013 11:04 pm
Forum: ZoneMinder 1.26.x
Topic: New install (1.26.3) on Slackware building but not running
Replies: 13
Views: 5546

Re: New install (1.26.3) on Slackware building but not runni

Some more findings after a day fiddling with ZM: 1. On slackware64-14.0, ZM doesnt detect libjpeg-turbo.. period. I recompiled it manually (ver. 1.2.0), to no avail. when I select 32bit color in the source's config page, I get no real time playback, and I get "libjpeg-turbo is required for JPEG enco...
by lpallard
Mon Oct 07, 2013 10:56 pm
Forum: ZoneMinder 1.26.x
Topic: Smearing images making system unusable
Replies: 27
Views: 10986

Re: Smearing images making system unusable

After I upgraded ffmpeg from the obsolete 0.11.1 on slackware64-14.0 to ffmpeg 1.2, I eliminated the smearing problem which was also creating false events. ffmpeg: ffmpeg version 1.2 Copyright (c) 2000-2013 the FFmpeg developers built on Oct 6 2013 22:57:37 with gcc 4.7.1 (GCC) configuration: --pref...
by lpallard
Mon Oct 07, 2013 9:24 pm
Forum: ZoneMinder 1.26.x
Topic: Upgrade to 1.26.4?
Replies: 6
Views: 2740

Re: Upgrade to 1.26.4?

I just went to my fresh install of ZM by clicking on the "v1.26.3" version number at the top of the main page and I got:

"You are running the most recent version of ZoneMinder, v1.26.3.
No update is necessary."

SO I wonder how you guys got a notification that a new version was available?!
by lpallard
Sun Oct 06, 2013 5:26 pm
Forum: ZoneMinder 1.26.x
Topic: New install (1.26.3) on Slackware building but not running
Replies: 13
Views: 5546

Re: New install (1.26.3) on Slackware building but not runni

"My guess is that the frameserver isn't keeping up, possibly due to insufficient hardware resources " Possible, but why would that be? I have a dual Opteron 6 Cores (total 12 cores) at 3.4GHz with 64GB RAM DDR3 1600, caching and temp folders for ZM are on a fast SSD... Right now, the framerate is se...
by lpallard
Sun Oct 06, 2013 2:48 pm
Forum: ZoneMinder 1.26.x
Topic: New install (1.26.3) on Slackware building but not running
Replies: 13
Views: 5546

Re: New install (1.26.3) on Slackware building but not runni

OK I figured out the libjpeg-turbo issue... Had to recompile ZM from scratch and reinstall it.. Strange though because if I am not mistaken, libjpeg-turbo is part of a full slackware install. Anyways, it was installed prior to installing ZM for the first time so it should have detected it. The socke...
by lpallard
Sat Oct 05, 2013 6:57 pm
Forum: ZoneMinder 1.26.x
Topic: New install (1.26.3) on Slackware building but not running
Replies: 13
Views: 5546

Re: New install (1.26.3) on Slackware building but not runni

I wonder if I should open new bug reports on the Github page... I have managed to install and make it run but Im having severe issues (still). In monitor mode, the logs are crippled with errors such as: 2013-10-05 14:33:01.627221 web_php 20219 ERR socket_sendto( /var/run/zm/zms-582107s.sock ) failed...
by lpallard
Sat Oct 05, 2013 6:25 am
Forum: ZoneMinder 1.26.x
Topic: New install (1.26.3) on Slackware building but not running
Replies: 13
Views: 5546

Re: New install (1.26.3) on Slackware building but not runni

[quote="knnniggett"]Out of all the badness in your logs, this is a good sign: [code]2013-10-04 17:53:43.275972 zmc_m1 17632 INF Monitor-1: 2000 - Capturing at 29.41 fps zm_monitor.cpp 2766[/code] It means your camera is likely recording fine. Although I recommend you crank down the fps. 5 fps is ple...
by lpallard
Fri Oct 04, 2013 10:23 pm
Forum: ZoneMinder 1.25.x
Topic: Zoneminder 1.25 not building on modern GCC compilers (4.7)
Replies: 9
Views: 3297

Re: Zoneminder 1.25 not building on modern GCC compilers (4.

FYI, Ive ended up trying the latest release (1.26.3) which built and installed just fine! :D but cant get it running...

See http://www.zoneminder.com/forums/viewto ... 30&t=21479 for my new thread ;)

Thanks!!
by lpallard
Fri Oct 04, 2013 10:21 pm
Forum: ZoneMinder 1.26.x
Topic: New install (1.26.3) on Slackware building but not running
Replies: 13
Views: 5546

New install (1.26.3) on Slackware building but not running

Thanks to everyone who contributed to this great project, I could finally get ZM to run on my slackware64-14 server with version 1.26.3. I however have serious issues to get it going. After a successful compilation and installation with [code]./configure --with-ffmpeg=/usr/bin/ --with-webdir=/var/ww...
by lpallard
Sun Aug 04, 2013 6:20 pm
Forum: ZoneMinder 1.25.x
Topic: Zoneminder 1.25 not building on modern GCC compilers (4.7)
Replies: 9
Views: 3297

Re: Zoneminder 1.25 not building on modern GCC compilers (4.

Its not working, or alt least I failed to modify the source properly... I still get the same output. TO be honest, there are a few places in his procedure where I didnt know what to do. For example, he was sometimes getting errors that I wasnt. So should I modify the code like he's suggesting or not...
by lpallard
Sun Aug 04, 2013 5:14 pm
Forum: ZoneMinder 1.25.x
Topic: Zoneminder 1.25 not building on modern GCC compilers (4.7)
Replies: 9
Views: 3297

Re: Zoneminder 1.25 not building on modern GCC compilers (4.

I will be trying that today. Obviously, if this works well, it should be pushed to the ZM devs so they can perhaps release 1.25.X or 1.26?..
by lpallard
Fri Aug 02, 2013 1:33 am
Forum: ZoneMinder 1.25.x
Topic: Zoneminder 1.25 not building on modern GCC compilers (4.7)
Replies: 9
Views: 3297

Re: Zoneminder 1.25 not building on modern GCC compilers (4.

knnniieggt I have applied the patch as you provided and it seems to have patched fine. ./configure goes well and finishes without errors but make throws a lot of errors: [code]g++ -DHAVE_CONFIG_H -I. -I.. -I/usr/include -I/usr/include -Wall -Wno-sign-compare -I/usr/include -g -O2 -MT zm_file_camera....
by lpallard
Fri Jul 26, 2013 8:41 pm
Forum: ZoneMinder 1.25.x
Topic: Zoneminder 1.25 not building on modern GCC compilers (4.7)
Replies: 9
Views: 3297

Re: Zoneminder 1.25 not building on modern GCC compilers (4.

I have sent an email to the Devs hoping someone will help...
by lpallard
Sat Jul 20, 2013 1:18 am
Forum: ZoneMinder 1.25.x
Topic: Zoneminder 1.25 not building on modern GCC compilers (4.7)
Replies: 9
Views: 3297

Zoneminder 1.25 not building on modern GCC compilers (4.7)

Hello, I cannot believe nobody reported this on the forums, or I totally failed to find a thread that is related. Anyways, I am trying to build ZOneminder on a slackware64-14 machine with GCC 4.7 and it fails. Apparently, this is due to the fact that "unistd.h is no longer included in libstdc++" in ...