Search found 45 matches

by tommy
Fri Jul 29, 2011 3:56 pm
Forum: ZoneMinder 1.25.x
Topic: ZoneMinder 1.25.0 - preview
Replies: 91
Views: 31103

Re: ZoneMinder 1.25.0 - preview

by tommy
Mon Jul 25, 2011 3:35 pm
Forum: ZoneMinder 1.24.x
Topic: ./configure zoneminder and problems
Replies: 12
Views: 4395

Re: ./configure zoneminder and problems

I'm on PCLinuxOS.
Had the same compile errors, " ...not declared...", with 1.25.0 pre-release.
Added this to zm_user.cpp:

#include <string.h>
#include <stdlib.h>
#include <time.h>
#include <ctype.h>

Compiled ok after that.
by tommy
Sun May 22, 2011 10:09 pm
Forum: ZoneMinder 1.24.x
Topic: Can't turn progress bar off and on
Replies: 0
Views: 512

Can't turn progress bar off and on

I installed the recently released 1.24.3. My previous installation was 1.22.0. In that release the progress bar functioned very smoothly. In this release I find the progress bar to be quite jerky. As well, it frequently doesn't complete those last few seconds. From the Options>Help, it seems this wa...
by tommy
Thu May 19, 2011 6:34 pm
Forum: ZoneMinder 1.24.x
Topic: Solved: Watch window not displaying events
Replies: 12
Views: 3348

Re: Solved: Watch window not displaying events

Here is an excerpt from the zm_create.sql script after running ./configure. insert into Config set Id = 115, Name = 'ZM_OPT_CONTROL', Value = '', Type = 'boolean', DefaultValue = 'no', Hint = 'yes|no', Pattern = '(?i-xsm:^([yn]))', ......... insert into Config set Id = 116, Name = 'ZM_OPT_TRIGGERS',...
by tommy
Thu May 19, 2011 2:38 am
Forum: ZoneMinder 1.24.x
Topic: Solved: Watch window not displaying events
Replies: 12
Views: 3348

Re: Watch window not displaying events

I have had this same problem since using the svn. It seems that the initial database creation script is setting an empty string for several values. Any boolean value with a default of "yes" is being assigned 1, any default of "no" is being left empty. This results in syntax errors in some of the jav...
by tommy
Tue Jan 11, 2011 2:11 pm
Forum: ZoneMinder 1.24.x
Topic: USB camera on but no video displayed, just white screen
Replies: 2
Views: 1505

I had the same problem. Have you tried the latest fix from this thread?
http://www.zoneminder.com/forums/viewto ... c&start=15
by tommy
Tue Jan 11, 2011 3:35 am
Forum: User Contributions
Topic: [FIX] ZM 1.24.2 "Error, failed to query crop"
Replies: 27
Views: 34922

I'm using the latest svn of both ffmpeg and Zoneminder on PCLINUXOS. All the patches mentioned in this thread have been implemented. I was having the same problem with my Creative PC-CAM300 usb camera as celsian reported in his post on Mar 09,2010 "Error, failed to query crop capabilities /dev/video...
by tommy
Sun Sep 02, 2007 6:25 pm
Forum: User Contributions
Topic: Getting ZoneMinder into debian and ubuntu
Replies: 91
Views: 57936

Here is an explanation of why the bit_test is set to 1 from the author of the BTTV driver Gerd Knorr:

http://marc.info/?l=linux-kernel&m=98097940526322&w=2
by tommy
Sun Sep 02, 2007 4:56 am
Forum: User Contributions
Topic: Getting ZoneMinder into debian and ubuntu
Replies: 91
Views: 57936

As regards the 5 minute boot up: I had the same problem with this card. This is what fixed it for me. http://tvtime.sourceforge.net/problems.html excerpt: 3. bttv takes a long time to load On some cards without a tuner, bttv can take a long time to load (a few minutes). If you see this problem, try ...
by tommy
Thu Mar 30, 2006 6:21 pm
Forum: ZoneMinder Previous Versions
Topic: jpeg quality 2 - the mission
Replies: 4
Views: 1622

Yes this is to fix that problem. If you can't use the patch program, it's easy to make the changes manually. The patch is only 3 lines. The lines with the"@" are the approximate line numbers in zm_image.cpp. Just type in the lines that are preceded with a "+" and delete the line that is preceded wit...
by tommy
Wed Mar 29, 2006 12:14 am
Forum: ZoneMinder Previous Versions
Topic: make not "making"
Replies: 42
Views: 23796

Your first post shows you in the "scripts" directory. Shouldn't you be up a level to run Make?

thanks
tommy
by tommy
Mon Mar 27, 2006 12:54 pm
Forum: ZoneMinder Previous Versions
Topic: jpeg quality
Replies: 10
Views: 3375

Doesn't the set defaults undo the previous set quality?

thanks
tommy
by tommy
Mon Mar 27, 2006 11:40 am
Forum: ZoneMinder Previous Versions
Topic: jpeg quality
Replies: 10
Views: 3375

I have one before the start compress in Image::WriteJpeg and one before the start compress in Image::EncodeJpeg. Is one of those redundant? I was implementing what I read at http://apodeline.free.fr/DOC/libjpeg/libjpeg-2.html "You can set all the parameters to reasonable defaults by calling jpeg_set...
by tommy
Sat Mar 25, 2006 12:09 am
Forum: ZoneMinder Previous Versions
Topic: jpeg quality
Replies: 10
Views: 3375

Possible Fix

This seems to be working for me: --- zm_image.cpp.original 2006-01-17 02:56:30.000000000 -0800 +++ zm_image.cpp 2006-03-24 15:37:13.000000000 -0800 @@ -270,6 +270,7 @@ cinfo->in_color_space = JCS_RGB; /* colorspace of input image */ } jpeg_set_defaults( cinfo ); + jpeg_set_quality( cinfo, quality, f...
by tommy
Mon Feb 27, 2006 7:22 am
Forum: ZoneMinder Previous Versions
Topic: No Play All button, problem creating Video
Replies: 1
Views: 1245

No Play All button, problem creating Video

ZM 1.22.0 Celeron 400 192M Debian Linux Kernel 2.6.8 Capture card 1 BTTV chip with 4 inputs Web server thttpd/2.25b PHP 5.0.5-3 (cgi-fcgi) Had a similar problem to the one I posted as "jpegtopnm: WRITING PPM FILE".When creating a video, all the output from ffmpeg was appearing in the window under th...