Search found 68 matches

by david1234
Thu Nov 26, 2020 3:25 pm
Forum: ZoneMinder 1.34.x
Topic: unable to connect to API V1.34.22
Replies: 10
Views: 167

Re: unable to connect to API V1.34.22

I notice I have 2 files with the name in 2 places /etc/apache2/sites-enabled/zoneminder.conf /etc/apache2/sites-available/zoneminder.conf I cahgne both of them to what you post then I reload the apache service by sudo systemctl restart apache2.service chek to see if the everything is working using t...
by david1234
Thu Nov 26, 2020 2:09 pm
Forum: ZoneMinder 1.34.x
Topic: unable to connect to API V1.34.22
Replies: 10
Views: 167

Re: unable to connect to API V1.34.22

on the Pi I have the file here: /etc/apache2/sites-available/zoneminder.conf is this the same? this is the file: <VirtualHost *:80> DocumentRoot /usr/share/zoneminder/www ServerName zm ErrorLog /var/log/apache2/error.log # Order matters. This alias must come first. Alias /zm/cache "/var/cache/zonemi...
by david1234
Thu Nov 26, 2020 9:49 am
Forum: ZoneMinder 1.34.x
Topic: unable to connect to API V1.34.22
Replies: 10
Views: 167

Re: unable to connect to API V1.34.22

I'm using Pi I download pre-build image from here: https://zmrepo.zoneminder.com/ have ty to reach the the pesrson how put it - no success have try to go everything it said in the manual - still get the same "not found' answer OPT_USE_API is enabled reboot the pi and try again I have try with and wi...
by david1234
Wed Nov 25, 2020 2:23 pm
Forum: ZoneMinder 1.34.x
Topic: unable to connect to API V1.34.22
Replies: 10
Views: 167

unable to connect to API V1.34.22

Hello, I have a working zone-minder record camera , see camera online on browser but I can't login using API when I run this command from the server itself I get "Not Found" pi@raspberrypi:~$ curl -XPOST -d "user=David&pass=MyRealPassword!" http://10.0.0.105/zm/api/host/login.json {"name":"Not Found...
by david1234
Sun Nov 08, 2020 8:23 am
Forum: ZoneMinder 1.34.x
Topic: api doesn't work on raspberry pi 3 with buster OS
Replies: 5
Views: 666

Re: api doesn't work on raspberry pi 3 with buster OS

can someone help \guide maybe ?

I really love working with zoneminder and the API option could make this program 100% good for my needed

?
by david1234
Mon Aug 10, 2020 1:27 pm
Forum: ZoneMinder 1.34.x
Topic: api doesn't work on raspberry pi 3 with buster OS
Replies: 5
Views: 666

Re: api doesn't work on raspberry pi 3 with buster OS

pre-build image from here

Code: Select all

https://zmrepo.zoneminder.com/
by david1234
Sun Aug 09, 2020 10:29 am
Forum: ZoneMinder 1.34.x
Topic: create a code that change the "Running State"?
Replies: 9
Views: 1650

Re: create a code that change the "Running State"?

when I try to use https I get this replay curl: (7) Failed to connect to 10.0.0.105 port 443: Connection refused do I need to enable https? if yes - how to? OPT_USE_API is check and I enter AUTH_HASH_SECRET - but how is using it ? where do I need to enter it also mayeb this is the problem? I have tr...
by david1234
Sun Aug 09, 2020 6:47 am
Forum: ZoneMinder 1.34.x
Topic: api doesn't work on raspberry pi 3 with buster OS
Replies: 5
Views: 666

Re: api doesn't work on raspberry pi 3 with buster OS

anything?

cant be the only one....

Thanks,
by david1234
Wed Aug 05, 2020 7:20 am
Forum: ZoneMinder 1.34.x
Topic: api doesn't work on raspberry pi 3 with buster OS
Replies: 5
Views: 666

api doesn't work on raspberry pi 3 with buster OS

Hello , I'm running zoneminder V1.34.16 on pi Buster OS. everything is working with the zoneminder (record 3 cameras all the time ,with sound - work great!) now I'm trying to use API , I have done what it said in the guide https://zmninja.readthedocs.io/en/latest/guides/validating-api.html AUTH_RELA...
by david1234
Tue Aug 04, 2020 1:41 pm
Forum: ZoneMinder 1.34.x
Topic: API doesn't work.HELP
Replies: 18
Views: 1399

Re: API doesn't work.HELP

I have a very very stupid qurstion

after I change the setting

Code: Select all

AUTH_RELAY is set to hashed
A valid AUTH_HASH_SECRET is provided (not empty)
AUTH_HASH_IPS is disabled
OPT_USE_APIS is enabled
OPT_USE_GOOG_RECAPTCHA is disabled
do I need to restart the service or better reboot the pi?
by david1234
Tue Aug 04, 2020 1:11 pm
Forum: ZoneMinder 1.34.x
Topic: API doesn't work.HELP
Replies: 18
Views: 1399

Re: API doesn't work.HELP

OK
this can also explain why the NinjaApp on my android phone doesn't work?
by david1234
Tue Aug 04, 2020 12:59 pm
Forum: ZoneMinder 1.34.x
Topic: API doesn't work.HELP
Replies: 18
Views: 1399

Re: API doesn't work.HELP

same resualt

Code: Select all

curl -XPOST -d "user=David&pass=Davidpass" http://10.0.0.105/zm/api/host/login.json
{"name":"Not Found","message":"Not Found","url":"\/api\/zm\/api\/host\/login.json"}pi@raspberrypi:~$
by david1234
Tue Aug 04, 2020 10:42 am
Forum: ZoneMinder 1.34.x
Topic: API doesn't work.HELP
Replies: 18
Views: 1399

Re: API doesn't work.HELP

can I connect to you also ?

I did everything it said in the manual ,
but the API is not working
I get error

Code: Select all

curl -XPOST -d "user=David&pass=DavidPass" http://10.0.0.105/zm/api/login.json
{"name":"Not Found","message":"Not Found","url":"\/api\/zm\/api\/host\/login.json"
Thanks,
by david1234
Mon Aug 03, 2020 8:33 am
Forum: ZoneMinder 1.34.x
Topic: create a code that change the "Running State"?
Replies: 9
Views: 1650

Re: create a code that change the "Running State"?

me again .....

any more ideas?

what could be wrong ?
maybe missing permission ?

can some one post the full system setting needed to make the api work?
I'm not an expert - so maybe I'm missing a simple setting ?
can't be that hard to make this work

Thanks ,