Search found 63 matches

by MILxDOT
Tue Apr 03, 2012 5:32 pm
Forum: ZoneMinder 1.24.x
Topic: Zoneminder on Mac OS X Server - Now Working!
Replies: 22
Views: 37427

Re: Zoneminder on Mac OS X Server - Now Working!

I did have this working other than it didn't show FPS in the camera view and the system load status didn't work quite right. But it was definitely usable. I wish that I could dedicate more time to helping maintain ZM on Mac OSX but instead it is SO much easier to just use Ubuntu 12.04 LTS which has ...
by MILxDOT
Mon Feb 13, 2012 1:29 am
Forum: ZoneMinder 1.25.x
Topic: filter.js - line:14 - form.elements.autoUpload is undefined
Replies: 2
Views: 1365

Re: filter.js - line:14 - form.elements.autoUpload is undefi

I can confirm this on 1.25.0 as well

From the log:

Component: web_js
Level: ERR
Message: form.elements.autoUpload is undefined
File: http://urlormyzmbox.com/skins/classic/v ... /filter.js

Running Ubuntu Server 11.10 amd64

Any fixes would be appreciated.
by MILxDOT
Tue May 31, 2011 6:10 pm
Forum: ZoneMinder 1.24.x
Topic: Zoneminder on Mac OS X Server - Now Working!
Replies: 22
Views: 37427

Re: Zoneminder on Mac OS X Server - Now Working!

Just an update. The only two things that I see that aren't working properly are:

1. "FPS" not showing in the live cam view area

2. System "Load" not showing - probably an easy fix just need to modify for mac system load.

I will try to monkey with those two things when I get some time.
by MILxDOT
Tue May 31, 2011 1:48 am
Forum: ZoneMinder 1.24.x
Topic: Zoneminder on Mac OS X Server - Now Working!
Replies: 22
Views: 37427

Re: Zoneminder on Mac OS X Server - Now Working!

We finally have Zoneminder working on Mac OS X 10.7 Lion! Although it is working pretty good so far I still have quite a bit of work/clean-up to do. To resolve the shared memory permissions issue I got lazy and just added _www to all of the groups that root belonged to...LOL! not secure but works fo...
by MILxDOT
Mon May 30, 2011 8:53 pm
Forum: ZoneMinder 1.24.x
Topic: Zoneminder on Mac OS X Server - Now Working!
Replies: 22
Views: 37427

Re: Zoneminder on Mac OS X Server - almost there

/var/log/system.log Looks like I have some permissions issues to deal with after I run to work for a little bit. Thanks! May 30 15:38:50 macserver ReportCrash[5462]: Saved crash report for zma[5463] version ??? (???) to /Library/Logs/DiagnosticReports/zma_2011-05-30-153850_localhost.crash May 30 15:...
by MILxDOT
Mon May 30, 2011 8:23 pm
Forum: ZoneMinder 1.24.x
Topic: Zoneminder on Mac OS X Server - Now Working!
Replies: 22
Views: 37427

Re: Zoneminder on Mac OS X Server - almost there

I am not having any luck getting the standard web interface to record any images or stay green even though our zmc test is running without error. What would be the next step in troubleshooting why zmc will manually run without error...but it is not working well with the web interface or possibly the...
by MILxDOT
Mon May 30, 2011 6:55 pm
Forum: ZoneMinder 1.24.x
Topic: Zoneminder on Mac OS X Server - Now Working!
Replies: 22
Views: 37427

Re: Zoneminder on Mac OS X Server - almost there

Some progress. I ran the following command: sysctl -w kern.sysv.shmmax=134217728 kern.sysv.shmmin=1 kern.sysv.shmmni=32 kern.sysv.shmseg=8 kern.sysv.shmall=134217728 and then ran: /usr/local/bin/zmc -m 1 Here is a snippet of the output: ????'] 05/30/11 13:48:38.654387 zmc_m1[68507].DB4-zm_remote_cam...
by MILxDOT
Mon May 30, 2011 6:31 pm
Forum: ZoneMinder 1.24.x
Topic: Zoneminder on Mac OS X Server - Now Working!
Replies: 22
Views: 37427

Re: Zoneminder on Mac OS X Server - almost there

Ah I see...this is what I should have done? macserver:bin root# export ZM_DBG_PRINT=1 macserver:bin root# export ZM_DBG_LEVEL=5 macserver:bin root# export ZM_DBG_LOG=zm.log macserver:bin root# /usr/local/bin/zmc -m 1 05/30/11 13:28:16.989742 zmc_m1[140733193456445].INF-zm_debug.c/228 [Debug Level = ...
by MILxDOT
Mon May 30, 2011 5:41 pm
Forum: ZoneMinder 1.24.x
Topic: Zoneminder on Mac OS X Server - Now Working!
Replies: 22
Views: 37427

Re: Zoneminder on Mac OS X Server - almost there

I updated zm_debug.c to reflect getpid vs syscall. Here is what I get now: (gdb) run -m 1 Starting program: /usr/local/bin/zmc -m 1 Reading symbols for shared libraries +++++++++++++++.......................... done Program exited with code 0377. (gdb) bt No stack. (gdb) info registers The program h...
by MILxDOT
Mon May 30, 2011 3:55 pm
Forum: ZoneMinder 1.24.x
Topic: Zoneminder on Mac OS X Server - Now Working!
Replies: 22
Views: 37427

Re: Zoneminder on Mac OS X Server - almost there

Thanks guys ..here is what I get: (gdb) run -m 1 Starting program: /usr/local/bin/zmc -m 1 Reading symbols for shared libraries +++++++++++++++.......................... done Program received signal SIGSYS, Bad system call. 0x00007fff8dab909a in syscall () (gdb) bt #0 0x00007fff8dab909a in syscall (...
by MILxDOT
Mon May 30, 2011 6:27 am
Forum: ZoneMinder 1.24.x
Topic: Zoneminder on Mac OS X Server - Now Working!
Replies: 22
Views: 37427

Re: Zoneminder on Mac OS X Server - almost there

Phil suggested running gdb against zmc. Here is the output: macserver:bin root# gdb zmc GNU gdb 6.3.50-20050815 (Apple version gdb-1655) (Sun May 1 07:04:07 UTC 2011) Copyright 2004 Free Software Foundation, Inc. GDB is free software, covered by the GNU General Public License, and you are welcome to...
by MILxDOT
Mon May 30, 2011 6:18 am
Forum: ZoneMinder 1.24.x
Topic: Zoneminder on Mac OS X Server - Now Working!
Replies: 22
Views: 37427

Re: Zoneminder on Mac OS X Server - almost there

I get the same results using either Snow Leopard Server 10.6.7 with Xcode 4.0.2 or even the new Mac OS X Lion Developer Preview 3 with the new Xcode 4.1 Preview 5.
by MILxDOT
Mon May 30, 2011 4:12 am
Forum: ZoneMinder 1.24.x
Topic: Zoneminder on Mac OS X Server - Now Working!
Replies: 22
Views: 37427

Zoneminder on Mac OS X Server - Now Working!

Here is another one of my documented attempts at getting Zoneminder to run natively on Mac OS X. This build was performed on a couple newer versions of Mac OS X with the same results. I am stuck trying to get the zmc capture daemon to run without giving the error Bad system call:12 Give me a shout i...
by MILxDOT
Mon Apr 11, 2011 3:44 am
Forum: ZoneMinder 1.24.x
Topic: ACTI IP cameras
Replies: 6
Views: 2586

Re: ACTI IP cameras

Glad you were able to get this working after your ZM rebuild. I haven't played with PTZ using Acti cams yet but look forward to it. I do know that you can use non-mjpeg modes with acti cams but I have yet to use them in that way as well. I haven't done any network efficiency type tests between mjpeg...
by MILxDOT
Sat Apr 09, 2011 1:06 am
Forum: ZoneMinder 1.24.x
Topic: ACTI IP cameras
Replies: 6
Views: 2586

Re: ACTI IP cameras

Insure your Acti is set for MJPEG Insure your resolution in the Acti matches the resolution in your ZM config Here are the relevant source entries in ZM Remote Protocol - HTTP Remote Method - Simple Remote Host Name - Admin:123456@192.168.xxx.xxx Remote Host Port - 80 Remote Host Path - /cgi-bin/cm...