Search found 50 matches

by jimkoh
Wed Aug 19, 2020 6:40 pm
Forum: ZoneMinder 1.34.x
Topic: ZM 1.34 on Debian 10
Replies: 9
Views: 819

Re: ZM 1.34 on Debian 10

I got zm working on my desktop. The problem is it's not version 1.34. How do I upgrade when clicking the version number gives me this: You are running the most recent version of ZoneMinder, v1.32.3. No update is necessary.
by jimkoh
Mon Aug 17, 2020 4:59 pm
Forum: ZoneMinder 1.34.x
Topic: ZM 1.34 on Debian 10
Replies: 9
Views: 819

Re: ZM 1.34 on Debian 10

I installed ZM on my main machine which is also running Debian 10 to see if I could get working. It gives me this error: sudo systemctl status zoneminder ● zoneminder.service - ZoneMinder CCTV recording and surveillance system Loaded: loaded (/lib/systemd/system/zoneminder.service; enabled; vendor p...
by jimkoh
Thu Aug 13, 2020 3:13 pm
Forum: ZoneMinder 1.34.x
Topic: ZM 1.34 on Debian 10
Replies: 9
Views: 819

Re: ZM 1.34 on Debian 10

This is what I get when I do apt --fix-broken install Do you want to continue? [Y/n] y (Reading database ... 98183 files and directories currently installed.) Removing ibritish (3.4.00-8) ... Can't locate Text/Iconv.pm in @INC (you may need to install the Text::Iconv module) (@INC contains: /etc/per...
by jimkoh
Wed Aug 12, 2020 5:55 pm
Forum: ZoneMinder 1.34.x
Topic: ZM 1.34 on Debian 10
Replies: 9
Views: 819

Re: ZM 1.34 on Debian 10

Yes, and this is what it wants to uninstall: Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages were automatically installed and are no longer required: apache2-data apache2-utils cpp-8 emacsen-common fakero...
by jimkoh
Wed Aug 12, 2020 3:55 pm
Forum: ZoneMinder 1.34.x
Topic: ZM 1.34 on Debian 10
Replies: 9
Views: 819

Re: ZM 1.34 on Debian 10

This is what I get when I try to install ZM.. Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies: libapt-pkg-perl : Depends: perl-base (>= 5.30.0-9)...
by jimkoh
Mon Aug 10, 2020 5:16 pm
Forum: ZoneMinder 1.34.x
Topic: ZM 1.34 on Debian 10
Replies: 9
Views: 819

ZM 1.34 on Debian 10

I upgraded my server to Debian 10 and wiped ZM. When I try to install following the wiki, I get a bunch of errors about unmet dependencies. A lot of them say they have no installation candidate?

Jim
by jimkoh
Mon May 04, 2020 4:07 pm
Forum: ZoneMinder 1.34.x
Topic: Zoneminder not starting
Replies: 15
Views: 2696

Re: Zoneminder not starting

I don't have a back up of the DB. It was dropped when I uninstalled ZM the first time. It sounds like things are a mess, so moving forward, what is the best way to wipe out ZM so I can start fresh? I used dpkg -r zoneminder and dpkg --purge zoneminder but I'm not sure that's enough. I also don't wan...
by jimkoh
Sat May 02, 2020 9:26 pm
Forum: ZoneMinder 1.34.x
Topic: Zoneminder not starting
Replies: 15
Views: 2696

Re: Zoneminder not starting

What do you mean by: Then add the old db back into mysql/mariadb and # zmupdate.pl to get the db to 1.34? Yes I added the external repo. /etc/apt/sources.list # deb cdrom:[Debian GNU/Linux 10.0.0 _Buster_ - Official amd64 DVD Binary-1 20190706-10:24]/ buster contrib main deb http://deb.debian.org/de...
by jimkoh
Thu Apr 30, 2020 9:54 pm
Forum: ZoneMinder 1.34.x
Topic: Zoneminder not starting
Replies: 15
Views: 2696

Re: Zoneminder not starting

I've followed the steps in the wiki but I only get version 1.32.3 which is what I was running before. The whole problem is it won't upgrade. This is what I get when I click the version number in the console.

You are running the most recent version of ZoneMinder, v1.32.3.

No update is necessary.
by jimkoh
Thu Apr 30, 2020 6:03 pm
Forum: ZoneMinder 1.34.x
Topic: Zoneminder not starting
Replies: 15
Views: 2696

Re: Zoneminder not starting

I typed the commands you suggested and now the console comes up, but the version says 1.32.3 and I'm getting errors when trying to stream from a camera. How can I upgrade to the latest version so I can start with a clean slate? I don't mind reinstalling everything, but I don't want to wipe out Maria...
by jimkoh
Wed Apr 29, 2020 8:41 pm
Forum: ZoneMinder 1.34.x
Topic: Zoneminder not starting
Replies: 15
Views: 2696

Re: Zoneminder not starting

My ZM database had been deleted so I removed ZM again and did an install from the 1.34 deb file. It looks like the database wasn't created. -- The job identifier is 71167. Apr 29 13:30:26 debian-server zmpkg.pl[15759]: DBD::mysql::st execute failed: Table 'zm.Config' doesn't exist at /usr/share/perl...
by jimkoh
Wed Apr 29, 2020 5:34 pm
Forum: ZoneMinder 1.34.x
Topic: Zoneminder not starting
Replies: 15
Views: 2696

Re: Zoneminder not starting

I initially tried updating but it didn't work. So I uninstalled ZM and tried to do a fresh install per the wiki and the result is what I posted.
by jimkoh
Wed Apr 29, 2020 5:19 pm
Forum: ZoneMinder 1.34.x
Topic: Zoneminder not starting
Replies: 15
Views: 2696

Re: Zoneminder not starting

I thought the database was created during the install process. How do I recreate it?
by jimkoh
Tue Apr 28, 2020 8:41 pm
Forum: ZoneMinder 1.34.x
Topic: Zoneminder not starting
Replies: 15
Views: 2696

Zoneminder not starting

I was running ZM 1.32 on Debian 10 and everything was working fine. I then tried to upgrade to 1.34 and it said I was already running the latest version. So I removed ZM so I could do a fresh install. Now I get the following error when starting the zoneminder.service. Any suggestions? zoneminder.ser...
by jimkoh
Sat Aug 17, 2019 6:27 pm
Forum: ZoneMinder 1.32.x
Topic: Only recording current day
Replies: 2
Views: 679

Re: Only recording current day

I found the problem. I had to change the storage setting for each camera under the General tab to my dedicated hard drive. I thought just changing it under the options/storage tab would be enough.