Search found 20 matches

by calmor15014
Tue May 26, 2020 11:26 pm
Forum: ZoneMinder 1.34.x
Topic: Face training seg fault, OpenCV works
Replies: 14
Views: 1461

SOLVED: Face training seg fault, OpenCV works

Enabled the face detection in objectconfig.ini again and it picked me up first time, 100% confidence even with sub-optimal camera angle and pretty crappy Facebook screen captures as training images. I'm impressed! For posterity's sake in case someone else runs up against this some day...: Problem Su...
by calmor15014
Tue May 26, 2020 3:42 pm
Forum: ZoneMinder 1.34.x
Topic: Face training seg fault, OpenCV works
Replies: 14
Views: 1461

Re: Face training seg fault, OpenCV works

Ok. Do note that a segfault at a library may not always imply the problem is with that library. It's where the program _eventually_ crashes. So even if it doesn't work without openBLAS, it may be a good idea to purge the pre-compiled libs and do it from scratch. Thanks... as mentioned, diagnosing s...
by calmor15014
Tue May 26, 2020 3:26 am
Forum: ZoneMinder 1.34.x
Topic: Face training seg fault, OpenCV works
Replies: 14
Views: 1461

Re: Face training seg fault, OpenCV works

So, definitely going WAY down the rabbit hole here... but before I scrap the whole thing and build a new one from scratch, I'd like to know why it's choking. Much of this is probably useless for most but it might help someone in the future... who knows. installed gdb and launched /usr/local/lib/pyth...
by calmor15014
Mon May 25, 2020 11:01 pm
Forum: ZoneMinder 1.34.x
Topic: Face training seg fault, OpenCV works
Replies: 14
Views: 1461

Re: Face training seg fault, OpenCV works

Took 1.jpeg down to 107x149, 3.0KiB. running face_detection 6.jpeg returns: 6.jpeg,45,93,131,6 Still segfaults on both zm_train_faces.py and directly running sudo -u www-data face_recognition --cpus 1 . 6.jpeg I'm not so familiar with this level of debugging but ran strace and see a few things to di...
by calmor15014
Mon May 25, 2020 10:27 pm
Forum: ZoneMinder 1.34.x
Topic: Face training seg fault, OpenCV works
Replies: 14
Views: 1461

Re: Face training seg fault, OpenCV works

Also interesting, if I run the command line program face_detection on 1.jpeg, it returns:

1.jpeg,77,112,181,8

If I run the program face_recognition, which expects a folder of known faces and then a file, and run both against 1.jpeg, it segfaults too regardless of where 1.jpeg lives.
by calmor15014
Mon May 25, 2020 10:17 pm
Forum: ZoneMinder 1.34.x
Topic: Face training seg fault, OpenCV works
Replies: 14
Views: 1461

Re: Face training seg fault, OpenCV works

It tries 3.jpeg first for some reason. It's 378x550, 26KiB.

When I delete 3, it tries 1.jpeg first. It's 153x214, 4.8KiB.

Segfaults either way. I'd also tried hog first then went to cnn, both segfaulted. running help(cv2) in the Python shell lists dnn as a module.
by calmor15014
Mon May 25, 2020 9:57 pm
Forum: ZoneMinder 1.34.x
Topic: Face training seg fault, OpenCV works
Replies: 14
Views: 1461

Re: Face training seg fault, OpenCV works

Thanks again for the quick response, and of course for all of your work on this and ZMNinja. I bought that for my Android and my work iPhone, as well as my wife's iPhone. Ultimately this isn't the most important thing ever, but was something I wanted to get up and running over the holiday weekend. T...
by calmor15014
Mon May 25, 2020 8:37 pm
Forum: ZoneMinder 1.34.x
Topic: Face training seg fault, OpenCV works
Replies: 14
Views: 1461

Re: Face training seg fault, OpenCV works

Didn't expect to hear from the man immediately... thanks! 1. If you have faces.dat in known_faces, delete it It never generated one, so nothing to delete. Folder and files all owned by www-data, but even root wouldn't generate it. 2. Turn on debug logs Debug logs are on per the documentation recomme...
by calmor15014
Mon May 25, 2020 6:31 pm
Forum: ZoneMinder 1.34.x
Topic: Face training seg fault, OpenCV works
Replies: 14
Views: 1461

Face training seg fault, OpenCV works

Hoping someone else might have had this problem and found a way around it. ZM1.34.15 Ubuntu 18.04 in Virtual Machine on Proxmox, upgraded from 16.04 MySQL server on remote machine OpenCV 4.2.0 built from source and seems to run normally 8 monitors - 4 Hikvision cameras, MJPEG stream and h.264 stream...
by calmor15014
Sat May 23, 2020 2:08 am
Forum: User Contributions
Topic: Record High-res H264 streams 24/7 with low CPU Load
Replies: 28
Views: 22813

Re: Record High-res H264 streams 24/7 with low CPU Load

Thanks a ton for this. I had to make a number of tweaks to get this to work on a remote MySQL installation, but was able to get it to run successfully with only recurring "Using a password on the command line interface can be insecure" warnings. It's pretty hack-ish but I'd be happy to share if you ...
by calmor15014
Thu Dec 14, 2017 1:28 am
Forum: ZoneMinder 1.30.x
Topic: Cameras randomly dropping out - 1.30.4 unique system install
Replies: 9
Views: 2804

Re: Cameras randomly dropping out - 1.30.4 unique system install

Installed in a full VM to test if the solution would change. All four cameras running normally (3 @ 15fps, 1 still testing @ 4fps) with no issue at all. Same host handling network and memory management duties, same NFS-mounted events and images storage, same "remote" SQL server (on the same host as ...
by calmor15014
Tue Dec 12, 2017 10:10 pm
Forum: ZoneMinder 1.30.x
Topic: Cameras randomly dropping out - 1.30.4 unique system install
Replies: 9
Views: 2804

Re: Cameras randomly dropping out - 1.30.4 unique system install

Another clue - I set debug down to DB4 level and am getting more information as expected. One thing that actually triggered more thought was a log entry by zmwatch, followed by a new zmc process being watched: 2017-12-12 17:00:26.102790 zmwatch 6299 INF Restarting capture daemon for Approach, shared...
by calmor15014
Tue Dec 12, 2017 6:26 pm
Forum: ZoneMinder 1.30.x
Topic: Cameras randomly dropping out - 1.30.4 unique system install
Replies: 9
Views: 2804

Re: Cameras randomly dropping out - 1.30.4 unique system install

Still haven't been able to update the cameras, but disabled three and dropped the remaining one to 4fps just to see if that would help. Still have the exactly-5-minutes RTP timed out error issue. Enabled debug logs and didn't notice anything special. I didn't notice the level of logging that the sou...
by calmor15014
Mon Dec 11, 2017 5:28 am
Forum: ZoneMinder 1.30.x
Topic: Cameras randomly dropping out - 1.30.4 unique system install
Replies: 9
Views: 2804

Re: Cameras randomly dropping out - 1.30.4 unique system install

Further investigation: Dropped one monitor down to 12fps. Still having the exactly-5-minutes error issue. I did try two monitors, and both started logged the RTP timeout at 5 minute intervals, but they were different minutes. Perhaps it is related to the camera itself... but not sure what it would b...
by calmor15014
Sun Dec 03, 2017 10:21 pm
Forum: ZoneMinder 1.30.x
Topic: Cameras randomly dropping out - 1.30.4 unique system install
Replies: 9
Views: 2804

Re: Cameras randomly dropping out - 1.30.4 unique system install

So I'm traveling, but have been analyzing the logs with just one monitor on Modect,and noted that I get an RTP timeout from zmc_m1 almost every five minutes almost exactly at 5 minutes. Even they are happening at xx:01:08 and xx:06:08 and they never vary more than +/- 3 seconds. Even if they don't o...