Search found 9 matches

by pok
Tue Dec 03, 2013 5:47 am
Forum: ZoneMinder 1.26.x
Topic: 1.26.4 Error while decoding frame errors
Replies: 34
Views: 18506

Re: 1.26.4 Error while decoding frame errors

alon wrote: ZM - v1.24.2
At least - change version to 1.26

But in fact in zm i see only frame differences... may be this help to you
by pok
Wed Nov 13, 2013 6:30 am
Forum: ZoneMinder 1.26.x
Topic: 1.26.4 Error while decoding frame errors
Replies: 34
Views: 18506

Re: 1.26.4 Error while decoding frame errors

I did it. Cam is D-lInk DCS-6113 tcp dum is quite big http://ftp.cinepost.ru/temp/from_rd/tcp_dump.zip As I can see these errors are not related to the process of encoding or decoding a ... this is an error getting a package ... Now image is present, so there are many solutions 1. ostrich - change ...
by pok
Fri Nov 08, 2013 6:56 am
Forum: ZoneMinder 1.26.x
Topic: 1.26.4 Error while decoding frame errors
Replies: 34
Views: 18506

Re: 1.26.4 Error while decoding frame errors

ATTENTION Everyone who cameras stopped work via rtsp after installing the release please provide external access to the broken camera. Or prepare the contents of log files from the database and tcpdump. Instructions for obtaining logs: 0. Set in ZM config maximum debug level 1. run console or xterm...
by pok
Tue Oct 29, 2013 10:49 am
Forum: ZoneMinder 1.26.x
Topic: 1.26.4 Error while decoding frame errors
Replies: 34
Views: 18506

Re: 1.26.4 Error while decoding frame errors

I am interested in your error problem. I wonder whether it is related to my forum topic about 'make' fails. I wrote about: avcodec_decode_video2 being only in libavcodec 54 and above. For example, the latest Ubuntu Server 12.04.03 version has libavcodec version 53 However, avcodec.decode_video is d...
by pok
Tue Oct 29, 2013 10:39 am
Forum: ZoneMinder 1.26.x
Topic: 1.26.4 Error while decoding frame errors
Replies: 34
Views: 18506

Re: 1.26.4 Error while decoding frame errors

zm_rtp_source.cpp are very different between 1.26.3 and 1.26.4. You have diffed zm_remote_camera_rtsp.cpp not zm_rtp_source.cpp It looks like the latest version will only work with H.264 since it is looking for NAL packets only. Yes, you are certainly right ... However, the error occurs at the mome...
by pok
Mon Oct 28, 2013 7:24 pm
Forum: ZoneMinder 1.26.x
Topic: 1.26.4 Error while decoding frame errors
Replies: 34
Views: 18506

Re: 1.26.4 Error while decoding frame errors

A temporary solution to this is to copy the 1.26.3 version of zm_rtp_source.cpp from the src directory into the 1.26.4 ... zm_rtp_source.cpp file versions 1.26.3 and 1.26.4 differ only in the type casting ... so strange a decision ... see diff below --- ZoneMinder-1.26.3/src/zm_remote_camera_rtsp.c...
by pok
Sat Oct 19, 2013 1:30 pm
Forum: ZoneMinder 1.26.x
Topic: 1.26.4 Error while decoding frame errors
Replies: 34
Views: 18506

Re: 1.26.4 Error while decoding frame errors

I tested the patch with FFmpeg 10.2/10.4 ... The error occurs after the call after avcodec_decode_video2, may be in the current version of FFmpeg something has changed ... I can not verify this for the next week: (you'll have to wait Usually a frame decoding error occurs if the ffmpeg is built witho...
by pok
Wed Sep 25, 2013 1:29 pm
Forum: ZoneMinder 1.26.x
Topic: ffmpeg can´t handle udp rstp streams
Replies: 26
Views: 11826

Re: ffmpeg can´t handle udp rstp streams

>i have found the reason. Short form: ffmpeg has problems with udp stream over rtsp. problem with fragmented packets... patch from warmcat (url see in messages, as new user i can`t post it) solved this problem... but it`s so old... I offer my patch (on current version - 1.26.3) see attached file
by pok
Tue Feb 14, 2012 1:49 pm
Forum: User Contributions
Topic: ZM 1.25.0 Performance Patch - Completed
Replies: 176
Views: 79489

Re: ZM 1.25.0 Performance Patch - Completed

mastertheknife , thank your fo your`s Patch. But i have some problem while use it... When remote camera work as ffmpeg stream - all ok, but picture some times destroyed. When remote camera work as rtsp source i have error "swscale does not support the codec format". Seems trouble in "mFormatContext...